Falcon no power

All Xbox 360 repair related topics to be kept to this section.

Re: Falcon no power

Postby Ikraam » Tue Aug 02, 2016 6:36 am

hey
thanks for the response yes i do get 5v on d5b1 and 3.3v on u5b1 but i get 1.4 volt on u5b2 and it gets hot
d5b1 gets hot two need two get a replacement mosfet for u5b2
do you think this will fix it
will be replacing u5b2 ,d5b1 and r5b3
i am hoping the short is from u5b2
Ikraam
Dedicated Member
Dedicated Member
Progress to next rank:
50%
 
Posts: 15
Joined: Tue Jul 26, 2016 8:33 pm
Location: South Africa
Has thanked: 1 time
Been thanked: 0 time

Re: Falcon no power

Sponsor

Sponsor
 

Re: Falcon no power

Postby matic_s » Tue Aug 02, 2016 6:59 pm

Ok, so the issue is probably on 1.8V power supply line from U5B2.
Btw U5B2 is not mosfet transistor, but it is voltage regulator.
If it is hot and the output voltage is lower then it should be the issue have to be something on output power line, not the voltage regulator itself.

I think it is dead one (or both) of two chips:
-HANA
-Southbridge (XSB chip)

Check these two chips if they are also hot.

For this kind of issue is probably blame the lighting through mains power cord.
User avatar
matic_s
VIP Member
VIP Member
 
Posts: 521
Joined: Mon Mar 09, 2015 9:14 pm
Location: Slovenia, EU
National Flag:
Slovenia
Has thanked: 28 times
Been thanked: 83 times
Set up: Achi IR PRO SC V3, Atten 850B, Hameg HM507

Re: Falcon no power

Postby Ikraam » Tue Aug 02, 2016 7:13 pm

Ok thanks

Will check and let u know
Ikraam
Dedicated Member
Dedicated Member
Progress to next rank:
50%
 
Posts: 15
Joined: Tue Jul 26, 2016 8:33 pm
Location: South Africa
Has thanked: 1 time
Been thanked: 0 time

Re: Falcon no power

Postby Ikraam » Wed Aug 03, 2016 9:41 am

ok not one of those chips is getting hot at all

do you think i still need to replace them ???
pls advise
Ikraam
Dedicated Member
Dedicated Member
Progress to next rank:
50%
 
Posts: 15
Joined: Tue Jul 26, 2016 8:33 pm
Location: South Africa
Has thanked: 1 time
Been thanked: 0 time

Re: Falcon no power

Postby Ikraam » Wed Aug 03, 2016 9:43 am

replaced everything except the southbridge and hana
u5b2 and diode still getting hot and still no power when pressing the power button

looks like i need to chuck this board
Ikraam
Dedicated Member
Dedicated Member
Progress to next rank:
50%
 
Posts: 15
Joined: Tue Jul 26, 2016 8:33 pm
Location: South Africa
Has thanked: 1 time
Been thanked: 0 time

Re: Falcon no power

Postby matic_s » Wed Aug 03, 2016 9:10 pm

If you have power supply with current limit you can locate the issue with it.
Remove U5B2 and connect the power supply to them output. Set the voltage to 1.8V and slow increase the current. Then check wich chip becoming hot.

If you don't have power supply is only option to remove the chips and then check output voltage from U5B2.
I suggest you to remove the HANA chip first and then check 1.8V output from U5B2. If it will be ok replace the HANA and test the console. If still no ok remove Southbridge chip and again check voltage.
But I think that unfortunately both chips are dead (HANA + Southbridge).
User avatar
matic_s
VIP Member
VIP Member
 
Posts: 521
Joined: Mon Mar 09, 2015 9:14 pm
Location: Slovenia, EU
National Flag:
Slovenia
Has thanked: 28 times
Been thanked: 83 times
Set up: Achi IR PRO SC V3, Atten 850B, Hameg HM507

Re: Falcon no power

Postby Ikraam » Thu Aug 04, 2016 7:39 am

ok thanks for the response

will do and let you know
Ikraam
Dedicated Member
Dedicated Member
Progress to next rank:
50%
 
Posts: 15
Joined: Tue Jul 26, 2016 8:33 pm
Location: South Africa
Has thanked: 1 time
Been thanked: 0 time

Previous

Return to Xbox 360 Repairs

Who is online

Users browsing this forum: No registered users and 1 guest